Installare HP-Print

Comperata una stampata HP? Per me avete fatto un ottimo affare: Sono sempre stato pienamente soddisfatto!

la pagina web per i driver è:
http://hplipopensource.com/hplip-web/index.html

Installare il supporto per stampare con HP in Suse è semplice:
Andate in Yast2->Gestione pacchetti

Qui digitate “HP-” (ovviamente senza “) nello spazio ricerca.
scegliere:
hplib (almeno la ver.3.14.6), hplip-hpijs, hplip-sane, openPrintingPPDs-hpijs,openPrintingPPDs-hpijs-ghostscript
(nota: se si hanno problemi potete provare hplib-qt3 + policykit con HPlib), cups-ddk

POI
reportlab, xsane, python e python-base (dovrebbero essere già installati in ver.2), dbus-1-python, python-devel, cups-devel, python-qt4-util, ghostscript, cups-filter-ghostscript, ghostscript-font ghostscript-font-other, avahi-utils, libcrypto30, python-xml, python-notify, libusb-1, dbus-1-python-devel

Meglio:
gcc, make, libtool

Spero non essermi dimenticato nulla, nel caso avvertitemi!!!

Se fa anche fax installate il supporto FAX alifax.

Nota: Se non trova dei pacchetti vedete se avete il repo abilitato per Python.

Indirizzo repo:
http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_13.2/

Se usate zypper (come root):
http://hplipopensource.com/hplip-web/install/manual/distros/novell.html


zypper refresh

zypper –non-interactive –no-gpg-checks in –auto-agree-with-licenses avahi-utils cups cups-client cupsddk cups-devel dbus-1-devel python-gobject2 gcc-c++ ghostscript-library openssl libjpeg-devel net-snmp-devel glibc libtool libgphoto2-devel libusb-1_0-devel libusb-1_0-0 make wget python-imaging python-qt4 dbus-1-python-devel dbus-1-python python-devel python-xml libpython2_7-1_0 python-notify python xsane sane-backends-devel sane-backends

Solo per SUSE 12.2,12.3,13.1:


zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses avahi-utils cups cups-client cupsddk cups-devel dbus-1-devel python-gobject2 gcc-c++ ghostscript-library openssl libjpeg-devel net-snmp-devel glibc libtool libgphoto2-devel libusb-1_0-devel libusb-1_0-0 make wget dbus-1-python3 python3-gobject python3-gobject2-devel python3-devel python3-notify2 python3-pip python3-qt4 python3-qt4-devel dbus-1-python3-devel python3-reportlab python3-xml python3-lxml xsane sane-backends-devel sane-backends

pip3 install pillow

Per Suse 13.2:


zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses avahi-utils cups cups-client cupsddk cups-devel dbus-1-devel python-gobject2 gcc-c++ ghostscript-library openssl libjpeg-devel net-snmp-devel glibc libtool libgphoto2-devel libusb-1_0-devel libusb-1_0-0 make wget dbus-1-python3 python3-gobject python3-gobject2-devel python3-devel python3-notify2 python3-Pillow python3-qt4 python3-qt4-devel dbus-1-python3-devel python3-reportlab python3-xml python3-lxml xsane sane-backends-devel sane-backends

Dopo avviate l’interfaccia HP e per prima cosa andate su
Configure->Preference, e settate nel tab System_tray_icon che “Alwayse show” e Message_to_show sia “all” e che Check_and_notify_HPLIB_update sia non ceccato
Mentre nel tab Commands (Advance) ci sia già scritto nello spazio “Scan:”:
/usr/bin/xsane -V %SANE_URI%

Premete OK e andate di nuovo nel menu:
Device-> Diagnose_HPlib_Driver

Vi aprirà un terminale, scriverà in inglese (mannaggia) e dopo poco:

 Checking for Deprecated items....
 error: This distro (i.e suse 13.2) is either deprecated or not yet supported.
 The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):

È una cavolata perchè è supportata (anche pienamente), e quindi rispondete Yes o meglio y.

Se trova tutto procede fin dirvi :

 Please close this terminal manually.

Altrimenti vi domanda se può scaricare quello che gli manca e vi chiederà se può e (tranquilli) la vostra password d’amministratore.
Dato che qualche volta anche le cose non importanti sono necessarie segnatevi quello che vi dice che “non trovato”

OK???

Bene, adesso in Device->Setup_device e seguite le istruzioni e vedrete che scoprirà subito la stampate HP che volete!

Nel caso Device-> Diagnose_Queues e vedrete se è collegato.

Nota: Il supporto Wireless non è pienamente supportato nemmeno in Windows, non conosco il perchè.

Nota: Potete anche definirlo poi attraverso Yast->stampante, ma è una mia precedente guida.

Attenzione: Ricordatevi di definirla sempre in CUPS!

Se avete una stampante che non la riconosce potete trovare le definizioni-stampante qui:
http://hplipopensource.com/hplip-web/index.html
http://hplipopensource.com/hplip-web/supported_devices/index.html

Non supportate (ma sono tutte vecchie):

http://hplipopensource.com/hplip-web/supported_devices/unsupported.html

Accessori

La HP fabbrica oramai stampanti multifunzionali… Il più pratico per scannerizzare è XSane ed è anche quello supportato da HPlib. Tenete conto che potete avere tramite XSane (oltre l’invio email già integrato):

  • Sendfax, permette di spedire fax
  • Gocr, permette di riconoscere il testo dall’immagine

Per questi due bisogna installare i corrispondenti pacchetti sendfax e gocr.

 

Per il resto potete arrangiarvi a soli basta un pochino di logica e quindi:

Ciaoooooooooooooooooooooooooooooooooooooo

Precedente Fare menu e sottomenu kde Successivo LXQT